3CX Supply Chain Attack
Incident Report for Yorb Limited
Resolved
We have identified and assisted affected customers to remove any 3CX software they may have installed. At this stage the advice from 3CX and Security vendors is to not use the Desktop Application and continue to use the Web App.

Please see here for further information: https://www.3cx.com/blog/news/security-incident-updates/
Posted Apr 06, 2023 - 07:41 NZST
Identified
3CX has acknowledged the discovery of a security issue in both the Windows and Mac desktop applications. The advice from Yorb and the Vendor is for users to continue using the web app until they release a security update.

Further information is available from 3CX directly, Yorb will continue to monitor the situation closely.

https://www.3cx.com/blog/news/desktopapp-security-alert/
Posted Mar 31, 2023 - 08:58 NZDT
Investigating
We are aware of the current threat that is affecting our 3CX customers and we are working tirelessly to provide a swift and effective response.
Posted Mar 30, 2023 - 13:42 NZDT