Power Outage - Milson Palmerston North
Incident Report for Yorb Limited
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 08:37 NZDT
Monitoring
Good afternoon,

We are currently aware of a power out in the Milson area of Palmerston North, which is impacting multiple clients near the Airport and Railway road junction.
Site investigation is currently underway by Power Co and they have provided an estimated restoration time of 2:15 pm this afternoon.
We will continue to monitor the situation and support clients with restoration if required.

To review the PowerCo status of the situation, please refer to outages.powerco.co.nz

Have a great afternoon and Happy New Year.
The team at Yorb.
Posted Dec 31, 2024 - 11:44 NZDT
This incident affected: Internet Providers (Chorus).