We are happy to confirm that Microsoft has finalized their mitigation and testing. You should find services fully restored across the Azure environment.
Have a great afternoon. The Yorb Team
Posted Oct 10, 2025 - 14:54 NZDT
Update
Good afternoon everyone,
The Microsoft Azure team has advised that they’ve made some adjustments, and some users may now have full access restored.
If you’re still experiencing issues, please try refreshing your browser cache and logging in again. If the problem persists, it means the issue is still being resolved on Microsoft’s end.
Microsoft has indicated that we can expect another update within the next two hours.
Thank you for your patience while this is being worked on. The Yorb Team.
Posted Oct 10, 2025 - 12:50 NZDT
Identified
Good morning,
We are aware of reports of intermittent performance issues affecting some Microsoft Azure services this morning. Microsoft has not yet confirmed a region-wide outage for New Zealand or Australia, however there are indications of ongoing issues with Azure Front Door (AFD), Microsoft’s global traffic management and content delivery platform. Azure are currently investigating and we will continue to monitor closely for updates from the Microsoft Team.
Should you attempt to access any Azure hosted services, apps, or websites, you may find that: Slow loading or timing out completely Authentication attempts may be delayed or fail Inconsistent access to Microsoft-hosted dashboards or apps
Further issues may appear as: “Can’t reach service” or “timeout” messages Delays when logging in or applying permissions Automations or reports temporarily failing to complete
Please note that these outages may also hinder our ability to support certain requests. We apologise for the delay in our standard service but will provide further updates if Microsoft confirms an outage or if client impact becomes more widespread.
The Yorb team.
Posted Oct 10, 2025 - 10:15 NZDT
This incident affected: Microsoft Services (Microsoft Azure).