Hosted email fault
Incident Report for Yorb Limited
Resolved
This incident has been resolved.
Posted Feb 02, 2022 - 15:58 NZDT
Investigating
There is currently an issue with hosted email, at this stage emails will not be sent or received. We are working to identify and resolve the issue.
Posted Feb 02, 2022 - 10:50 NZDT
This incident affected: Yorb Products & Services (Web Hosting).