Internet outages with multiple providers
Incident Report for Yorb Limited
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 18:24 NZDT
Investigating
We are investigating reports of Internet outages for 2Talk and MyRepublic customers including 2Talk phones being affected. We are investigating the cause of these outages
Posted Mar 02, 2022 - 14:09 NZDT